Experiment: Uconnect untersuchen

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Experiment: Uconnect untersuchen

      Hi,
      habe gedacht ich mache endlich nach 3 Jahren mal einen Thread auf, der unter Umständen einigen interessieren könnte und ich hier im Forum nichts ähnliches finden konnte.

      In meinem Tipo ist ein 5 Zoll Uconnect verbaut, ab Werk mit Navi, aber ohne DAB, RVC und Live-Dienste.
      Ich konnte mich nie zufrieden damit geben, dass es unmöglich sei, irgendetwas davon nachzurüsten, undzwar originalgetreu. Nach studieren von technischen Dokumenten von Continental (Hersteller der Uconnects) und optische vergleiche des Motherboards verschiedener Ausführungen (5 Zoll und 7 Zoll) konnte ich nun feststellen, dass diese Einheiten, bis auf Ports und Gehäuse, absolut baugleich sind. Intern bei Continental nennen die sich vp2 refresh.
      Nicht nur im Tipo, sondern auch in einigen anderen Fiat Modellen sind solche Einheiten verbaut, selbst in ein paar Jeeps. Möglicherweise noch in weiteren anderen.

      Um es nochmal zu verdeutlichen, Motherboard sind in besagten Modellen absolut baugleich und gleich bestückt bis auf Ports, die Modellspezifisch sind. Im Vergleich vom 5er und 7er im Tipo etwa der grüne Display-Ausgang, dafür fehlen die Flexkabel-Steckverbinder des Displays und der Tasten dort vom 5 Zoll. Im Vergleich zu gewissen Jeeps und dem 500er mit Uconnect 5 Zoll (gibt 2 verschiedene 5er, ein älteres vp2 und eben unseres) ist die Displayeinheit optisch eine andere, dennoch sind die Steckverbinder die selben.

      Das wichtigste dabei ist aber der Punkt, dass sich die Uconnect dadurch umbauen lassen! Beispielsweise aus einem 5er Uconnect einen 7er machen, oder umgekehrt, ohne überteuert sich das gewünschte gebraucht online bestellen zu müssen.
      Der erste Hinweis darauf war, dass die Firmwares für die beiden Uconnects absolut die selben sind. dadurch sind Hardware- und Softwareseitig bei beiden System dasselbe möglich.

      Exklusive Funktionen vom 7er wie Carplay müssten dann auch auf dem 5er problemlos funktionieren. Habe es noch nicht probiert, aber die UI vom 5er muss dafür auch angepasst worden sein, sonst gehts nicht. Beim 500er scheint es mit dem kleinen aber zu funtionieren.
      DAB, FM, AM sind ebenfalls in einem Tuner-Chip integriert bei allen Modellen. Wenn man also den Fakra-Port reinlötet und das Gerät, bzw das BCM entsprechend codiert, sollte dies ebenfalls laufen.
      DAB auf diese Weise nachrüsten habe ich auch vor, leider gibt es auf der Platine meines 5er viele Lötstellen in der Nähe. Auf Bildern konnte ich sehen, dass der DAB Port weit oben aufgesetzt ist über dem GPS Port. Ich konnte leider im Internet keine Bilder vom Motherbaord eines 5er oder 7er Uconnect mit DAB Port finden, um die richtige Lötstelle finden zu können. Zum Beispiel ist bei den Uconnects neben der weißen Fakra Buchse eine Lötstelle für eine weitere Fakra Buchse. Konnte nichts genaueres darüber finden außer das bei manchen Uconnects in anderen Modellen stattdessen die UKW-Buchse dort verlötet ist. Es müssten sich dann beides um UKW Antenneneingänge handeln, denn der Tuner-Chip hat tatsächlich theoretisch eine Twin-Tuner Fähigkeit!

      Ich habe nun vor ein paar Tests bzw Experimente anzustellen. Ich besorge mir vielleicht ein 7er Bildschirm und versuche diesen im 5er anzuschliessen. Dafür muss ich dann die 2 Ports reinlöten. Ich vermute aber, dass die technischen Spezifikationen die das Gerät nur kann, in einem EEPROM auf dem Board gespeichert sind. Infos wie beispielsweise, ob es nun ein 5 Zoll oder 7 Zoll Display verbaut hat oder ob das Gerät externe Tasten besitzt usw. Die müsste man dann entsprechend abändern. Das müsste ich mal in Erfahrung bringen.
      Genauso ob man irgendwie ins WinCE kommt bzw. den Explorer hervorholen kann, um genauer das System ansehen zu können.

      Habe auch schon versucht eine RVC an das 5er anzuschliessen (Infos in einem anderen Thread), aber bis heute funktioniert sie nicht. Schwarzer Bildschirm. Habe dann ein technisches Handbuch vom Tipo und dessen Steuergeräte auftreiben können und herausgefunden, dass der BCM ebenfalls über Lin-Bus mit der Kamera kommuniziert. Deshalb hat die original Kamera auch 2 Ports mehr. Davon habe ich nirgendwo was lesen können. Ich vermute nun, der BCM gibt sie daher nicht frei im Uconnect, gibt auch eine Fehlermeldung. Wie es angeblich ein anderer User hier direkt und ohne Lin-Bus bei seinen 5er hinbekommen hatte, ist mir ein Rätsel, aber anders Thema.

      Erstmal soviel dazu. Ich hoffe das alle damit etwas anfangen können und verstehen welches Potential dahinter steckt^^

      PS. Hier noch 2 Fotos vom Motherboard des 5er sowie 7er.


      Uconnect 5


      Uconnect 7

      : Fiat Tipo 5T Weiß Easy 1.4

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von GE2012 ()

    • Ähm ja.

      Ganz ehrlich? Warum?
      Wenn du mit dem Funktionsumfang des 5" Uconnect nicht zufrieden bist dann schmeiß es einfach raus und kauf ein Android Radio.

      Mein Tipo: Fiat Tipo Sport 1,4T-Jet, Vollausstattung, Leistungssteigerrung von Pogea Racing 146PS 300Nm, Sommer Dotz Spa Dark 8x18" ET35 225/40 18", Winter MAK Milano black mirror 7x17" ET35 215/45 17" , H&R 40/35 Federn, Smoke Nebelscheinwerfer,K&N Sportluftfilter,Bremssättel schwarz lackiert, schwarze LED Seitenblinker, Schaltwegverkürzung Novitec,cleaner Kühlergrill ( Eigenbau), Heckklappe clean ( Schriftzug,Logo,Scheibenwischer entfernt), LED Facelift Heckleuchten, handgefertigte Edelstahl Auspuffanlage von Wimmer Rennsporttechnik 80er Doppelendrohr fahrzeugmittig, Sportlenkrad,MOMO Schaltknauf, Motoranbauteile lackiert, DTE Pedalbox, Hifiausbau Audison SR 5.600 Verstärker, Frontsystem Audison AV K6, Hecksystem Audison AV 6.5, Subwoofer Hertz MP 300 D4.3 Pro

    • Die Firmware kann perse schon mal nicht 100% identisch sein, weil das 5" eine andere Auflösung ausgeben muß als das 7".Wenn man tiefer kramt findet man garantiert noch mehr Unterschiede. Touchscreen Punkte zum Beispiel.

      Das die Hardware darin so halbwegs gleich ist, ist nicht verwunderlich. Das sind Standard Boards nach gewissen Vorgaben und gut ist.
      Entsprechende Firmware drauf und fertig.

      Hatte hier mal auch ein TearDown eines 7" Uconnects gepostet wo man die einzelnen Baugruppen gut sieht...

      Selbes Spiel hatte ich kürzlich bei meinem Android Navi.

      Selbe Hardware im Gerät aber unterschiedliche Monitore/Auflösung und daher auch unterschiedliche Firmwares seitens (chinesischem) Hersteller.
      Und Chinesen machen es sich meist recht einfach, wenn es einfach geht.
      Lounge SW Tjet l Pogea Racing l 19" VW Pretoria Felgen l EBC Brakes l H&R Federn l LED Abblendlicht l Stelvio LED Nebelscheinwerfer l Audiotec Fisher Komplettausbau l 9" Android Custom Navi
    • Tobir83 schrieb:

      Ähm ja.

      Ganz ehrlich? Warum?
      Wenn du mit dem Funktionsumfang des 5" Uconnect nicht zufrieden bist dann schmeiß es einfach raus und kauf ein Android Radio.
      Weil mir erstens ein Android Radio nicht gefällt, weil das Betriebssystem dafür nicht vorgesehen ist und die Bootzeit sicherlich länger ist. Außerdem ist die UI bei denen, die ich bisher gesehen hab, einfach nicht ausgereift und eben zu Smartphone-fixiert. Ist aber meine persönliche Meinung. Außerdem weiß ich nicht, wie sehr diese Radios das CAN-Bus beim Tipo ausnutzen kann und welche Funktionen (zb. Tachoinfos) dadurch wegfallen könnten. Außerdem muss das PDC über Can-Bus ausgelesen werden können und über die Lautsprecher wiedergegeben werden können, am besten mit Zonen wie beim original. Ansonsten eine gute Wahl.

      : Fiat Tipo 5T Weiß Easy 1.4

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von GE2012 ()

    • 19inchwheeler schrieb:

      Die Firmware kann perse schon mal nicht 100% identisch sein, weil das 5" eine andere Auflösung ausgeben muß als das 7".Wenn man tiefer kramt findet man garantiert noch mehr Unterschiede. Touchscreen Punkte zum Beispiel.

      Das die Hardware darin so halbwegs gleich ist, ist nicht verwunderlich. Das sind Standard Boards nach gewissen Vorgaben und gut ist.
      Entsprechende Firmware drauf und fertig.

      Hatte hier mal auch ein TearDown eines 7" Uconnects gepostet wo man die einzelnen Baugruppen gut sieht...

      Selbes Spiel hatte ich kürzlich bei meinem Android Navi.

      Selbe Hardware im Gerät aber unterschiedliche Monitore/Auflösung und daher auch unterschiedliche Firmwares seitens (chinesischem) Hersteller.
      Und Chinesen machen es sich meist recht einfach, wenn es einfach geht.
      Die erhältlichen Firmwares für den Tipo (356) sind universell für den 5er und 7er, da die Hardware identisch ist. Da es ein Windows CE Gerät ist, wird es über alle notwendigen Treiber verfügen. Das Display benötigt auch keine Treiber. Wird einfach ein LVDS-Display sein. Die richtige Auflösung und die richtige Benutzeroberfläche für die jeweilige Displaygröße wird dann eben festgelegt beim Booten.
      Bei Android ist es was anderes, da muss zwingend für verschiedene Auflösungen eine Firmware kreiert werden bzw dafür gesorgt werden. Bei Windows ist dies kein Problem.
      Ich habe außerdem mal ein nicht näher beschriebenes Bild eines 5er Uconnect mit 7er UI gesehen, müsste ich mal raussuchen.

      Wenn man in einer der Firmwaredateien reinschaut dann sieht man auch, dass als Modell lediglich VP2 genannt wird.
      Auf meinem 5er läuft schon länger die im Internet erhältliche Version 23.01.93.11, von der hier im Forum die Rede war, sie würde nur auf dem 7er funktionieren. Hab die mir damals auch angeschaut und konnte keine Gründe finden, warum sie nicht auch auf dem 5er laufen sollte. Deshalb hab ich sie installiert. Danach habe ich mich auch in den englischen und italienischen Forums umgeschaut. Die wissen auch Bescheid darüber.
      Das VP2R7 steht wohl dann für die 7. Revision der VP2-Baureihe, und nicht für ein 7er Uconnect. Ist aber nur eine Vermutung

      Schaue mir heute mal eine Conti Firmware für den Tipo an.

      : Fiat Tipo 5T Weiß Easy 1.4

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von GE2012 ()